PART - III

कम्प्युटर साइंस / COMPUTER SCIENCE

(Vocational Component under General Stream)

(தமிழ் வழங்கும் வடிவில் / Tamil & English Versions)

[ விளக்கத்துடன் மதிப்புப்பாட்டின் மதிப்பு: 150

Time Allowed: 3 Hours ]

[Maximum Marks: 150]

Instructions:

(1) Check the question paper for fairness of printing. If there is any lack of fairness, inform the Hall Supervisor immediately.

(2) Use Black or Blue ink to write and pencil to draw diagrams.

Note:

(i) Candidates should answer all the questions in PART - I (Objective type) (1 to 75) in the separate OMR Answer Sheet supplied. (Refer instructions given in the OMR Answer Sheet).

(ii) The number of the sign ‘–’ (dash) as found in the right - hand top corner of the Question Paper i.e. [ 1 ] (1) or [ 2 ] (2) or [ 3 ] (3) or [ 4 ] (4) should be shaded in the OMR Answer Sheet using Black ink.

(iii) Time allotted for answering question numbers 1 to 75 is first 75 minutes.

(iv) PART - II and PART - III questions (76 to 110) should be answered in the main answer-book.
Choose the most appropriate answer:

1. Which view allows to view miniature images of all the slides in the Presentation?
   (A) Slide Sorter   (B) Normal   (C) Notes   (D) Outline

2. Which one of the following is called the entry-check loop in C++?
   (A) do...while   (B) while   (C) continue   (D) break

3. In StarOffice Writer which command is used to insert more than one row in the table?
   (A) Table → Insert → Rows   (B) Format → Insert → Rows
   (C) Tools → Insert → Rows   (D) File → Rows → Insert

4. A category of IT enabled services pertaining to collection, digitization and processing of data coming from various source is:
   (A) Tele - Medicine   (B) Website Service
   (C) e - Governance   (D) Data Management
5. In C++, the body of the class is terminated by:
   (A) :       (B) ;       (C) ()       (D) ;

6. Which of the following is used to uniquely identify a record in a database table?
   (A) Field     (B) Record
   (C) File      (D) Primary Key

7. The First Electronic Spread Sheet:
   (A) Lotus 1-2-3     (B) VisiCalc
   (C) Excel          (D) Improve

8. Which is a telephone based shared service center for a specific customer activities?
   (A) Data Management (B) Call Center
   (C) Digitization   (D) Morphing

9. Which key is used to make the selected text bold in StarOffice Writer?
   (A) Ctrl + A       (B) Ctrl + B       (C) Ctrl + C       (D) Ctrl + D
10. In C++ when should a function be declared private, protected, public, or static?
   (A) Private    (B) Protected    (C) Public    (D) Static

In C++ which access specifier is used to access the members only from within the class?
   (A) Private    (B) Protected    (C) Public    (D) Static

11. Which command is used to change the column width of a Worksheet in StarOffice Calc?
   (A) Format → Width → Column   (B) Format → Column → Height
   (C) Format → Height → Column   (D) Format → Column → Width

12. Which of the following is the extension of shockwave format?
   (A) .snd    (B) .swf    (C) .snf    (D) .swd

13. Which of the following is the extension of shockwave format?
   (A) .snd    (B) .swf    (C) .snf    (D) .swd

14. Which of the following is executed in the order of inherited class?
   (A) Polymorphism    (B) Destructor
   (C) Constructor    (D) Function
15. GIF என்பது என்னவாகும்?
(A) Graphic Information Format  (B) Graphic Interchange Format
(C) Graphic Interchange File  (D) Graphic Information File

Expansion of GIF:
(A) Graphic Information Format  (B) Graphic Interchange Format
(C) Graphic Interchange File  (D) Graphic Information File

16. C++ என்பது என்னவாகும்?
(A) Access specifier  (B) Attributes
(C) Methods  (D) Operator

In C++ Member functions are called:
(A) Access specifier  (B) Attributes
(C) Methods  (D) Operator

17. இவ்விளக்க என்பது என்னவாகும்?
(A) SQUARE()  (B) ROOT()  (C) SQRT()  (D) SQR()

Which function is used to find square root of a given number in StarOffice Calc?
(A) SQUARE()  (B) ROOT()  (C) SQRT()  (D) SQR()

18. இந்த உருவானது என்பது என்னவாகும்?
(A) File → Print  (B) Edit → Print
(C) Tools → Print  (D) Format → Print

Which of the following command is used to print the presentation?
(A) File → Print  (B) Edit → Print
(C) Tools → Print  (D) Format → Print
19. In C++ the mechanism of giving special meaning to an operator is called:
(A) Function Overloading  (B) Operator Overloading  
(C) Constructor Overloading  (D) Destructor Overloading

20. In C++ which statement would exit the current loop only?
(A) for  (B) switch  (C) struct  (D) break

21. In StarOffice Calc which of the following bar is used to display the current cell and its contents?
(A) Function  (B) Object  
(C) Formula  (D) Status

22. Which one of the following in C++ is memory box that hold values or constants?
(A) punctuators  (B) keywords  
(C) constants  (D) variables
23. C++ பிரகடனம் அண்மைக் குறிக்க வரையறுக்கப்பட்டுள்ள பண்பியலுக் குறிகளின் பக்திகள்?

(A) தொட்டிப்பட்டல்  (B) மீண்டும் பீட்டுதல்
(C) மீட்டுப்பட்டல்  (D) மீட்டுப்பட்டல்

Which one of the following is used to construct C++ basic statements?

(A) Symbols  (B) Operators
(C) Tokens  (D) Functions

24. C++ என்பது பாட்டியல் திருக்கலத்தில் பொருளான நம்பும்:

(A) ::           (B) & ?         (C) ? :        (D) &

In C++, which one of the following is called scope resolution operator?

(A) ::           (B) & ?         (C) ? :        (D) &

25. பல்கலைக்கழக வேலை விருதங்கள் வருகைகள் சிகம்பேருகம் தற்போதைய இந்துகையால் உள்ள கால் வினையேற்ற?

(A) 40   (B) 15   (C) 20   (D) 25

Reducing the frame count to less than how many frames per second causes the video to look jerky?

(A) 40   (B) 15   (C) 20   (D) 25

26. C++ என்று அறிக்கைகள் பெருவான்கழித்து குறுக்குப்பம் திருப்பது பாட்டியலுக் குறிகளில் உள்ள பண்பியலான:

(A) வலியுடன்  (B) அறிக்கை
(C) மீட்டுநிலை  (D) பண்பியலான

In C++ which function removes the memory of an object which was allocated by the constructor?

(A) Pointer  (B) Destructor
(C) Copy Constructor  (D) Modifier
27. In StarOffice Base which option is used to specify if the user should always enter a value for that field?
   (A) Entry Required  (B) Default Value  (C) Length  (D) Format

28. How many kinds of loops are there in C++?
   (A) four  (B) three  (C) two  (D) five

29. How many storage specifiers are there in C++?
   (A) One  (B) Two  (C) Three  (D) Four

30. DBMS
   (A) Data Base Management System  (B) Data Base Memory System  
   (C) Data Base Memory Storage  (D) Device Based Memory Storage

Expansion of DBMS:
   (A) Data Base Management System  (B) Data Base Memory System  
   (C) Data Base Memory Storage  (D) Device Based Memory Storage

31. In C++ a collection of variables of the same type is:
   (A) Function  (B) Operators  (C) Pinter  (D) Array
32. Which key is used to end the presentation?
(A) Ctrl    (B) Alt    (C) Delete    (D) Esc

33. Which of the following operators is used to combine sections of text in StarOffice Calc?
(A) :    (B) &    (C) !    (D) $

35. Which one of the following is a process to join the data from more than different tables in a Database?
(A) Sorting    (B) Filter    (C) Searching    (D) Merging

36. Which key is used to move the insertion point to the beginning of the line in StarOffice Writer document?
(A) Alt + Home    (B) Shift + Home    (C) Ctrl + Home    (D) Home
37. In StarOffice Calc, in Page Style Dialog Box which Check box should be clicked to print a Worksheet with gridlines?

(A) Sheet  (B) Page  (C) Grid  (D) Format

38. Which of the following function gets executed when an instance of a class comes into scope?

(A) Method  (B) Arguments  (C) Destructor  (D) Constructor

39. Which of the following is the most powerful feature of an Objected Oriented Programming language?

(A) Class  (B) Abstract  (C) Constructor  (D) Inheritance

40. In StarOffice Writer, the flashing vertical bar is called:

(A) Pointer  (B) Operators  (C) Insertion Point  (D) Key
41. The default top and bottom margins are in how many inches in StarOffice Writer.
(A) 1.25  (B) 0.5  (C) 1  (D) 1.5

42. In C++ which one of the following is used as prefix to destructor?
(A) ~    (B) @    (C) !    (D) #

43. Which of the following function copies Source String to Target String?
(A) Stringcopy()  (B) Strcpy()  (C) Strcmp()  (D) Strcopy()

44. Making and using duplicate hardware and software is called:
(A) Virus  (B) Ethics  (C) Piracy  (D) Cracking

45. The number of an element in the array int a [2] [4];
(A) 4  (B) 6  (C) 8  (D) 12
46. Real Audio / Real Video ஏவு அன்று அறிமுகப்படுத்தப்பட்டது؟
   (A) 1981    (B) 1995    (C) 1982    (D) 1994
In which year, Real Audio/Real Video format was developed?
   (A) 1981    (B) 1995    (C) 1982    (D) 1994

47. C++ என்ன கிரிபெ சம்பந்தத்தில் பலீடிக்கப்பட்டுள்ளது?
   (A) குணகம்    (B) இயற்பி    (C) பலீடிக்கம்    (D) பயன்கள்
In C++ which of the following is a special function that cannot be overloaded?
   (A) Constructor    (B) Destructor    (C) Operator    (D) Function

48. செயல்பாடான தகவல் தோற்ற கலிப்பரங்கி செயல்பாடோ அவள்
    பிறர்களிடம் தேவைகள் செயல்பாடு அவுக்கிரேற்றம்?
   (A) மொழிவரிசை    (B) மொழிவரிசை
   (C) மொழிவரிசையான    (D) அதிக வளையம்
Which is the illegal access to the network or computer system?
   (A) Ethics    (B) Virus    (C) Software    (D) Cracking

49. தமுக் ஆப்பிரிக் கணங்கள் வழியாக போருக்கான தினசரியை இயற்றி வழியாக
    அளவிப் பாகங்கள் விளக்கப்படும்?
   (A) Add    (B) Replace
   (C) Insert    (D) Suggestions
In StarOffice Writer which button is used to add the word to the dictionary?
   (A) Add    (B) Replace    (C) Insert    (D) Suggestions

50. CBT தலையான விளக்கம்:
   (A) Common Business Tool    (B) Calculator Based Tools
   (C) Computer Based Tutorials    (D) Computer Based Tools
Expansion of CBT:
   (A) Common Business Tool    (B) Calculator Based Tools
   (C) Computer Based Tutorials    (D) Computer Based Tools
51. Which of the following sign is used to make the cell address absolute in StarOffice Calc?
(A) #  (B) &  (C) $  (D) %

52. In C++ which of the following operator is used to access the members of a class?
(A) dot (.) (B) Semicolon (;) (C) Comma (,) (D) Colon (:)

53. In C++ which one of the following braces is used to enclose the body of a class?
(A) ()  (B) {}  (C) []  (D) <>

54. In C++ which function execute faster but require more memory space?
(A) cinline  (B) inline  (C) outline  (D) coutline

55. Which one of the following is the multiple branching statement in C++?
(A) switch  (B) if  (C) while  (D) do..while

[ אפילו/Half over]
56. Which of the following database consists of single data table?

(A) Relational (B) Flat - File
(C) Object Oriented (D) Hierarchical

57. In C++ which of the following operator when overloaded through a member function take one explicit argument?

(A) Unary (B) Ternary (C) Binary (D) Function

58. Which command is used to hide a slide?

(A) Tools → Show/Hide Show (B) Tools → Hide Show
(C) Format → Hide Slide (D) Slide Show → Show/Hide Slide

59. What value is stored in the variable c, if a = 5; c = a++?

(A) 5 (B) 6 (C) 0 (D) 10
60. Which one of the following reduces software complexity?
   (A) Polymorphism  (B) Inheritance  (C) Object  (D) Class

61. How many copy of the member variable is created for static data members in C++?
   (A) One  (B) Two  (C) Three  (D) Four

62. The name C++ was coined by:
   (A) Dennis Ritchie  (B) Dan Bricklin  (C) Rick Mascitti  (D) Bjarne Stroustrup

63. Which of the following act as place holders in the function prototype in C++?
   (A) variables  (B) typedef  (C) character  (D) enumerator
64. C++ மற்றும் இல்லாதுபட்டு விளக்கங்களை வலப்புறவுகளும் குறிப்பிட்டு பார்வைகளை விளக்கமாற்ற முடியும் மூன்று நிலைகளின் முதல் கோட்டைகள் செயல்பாடுகள் எதைப்படுத்தும்?

(A) மற்றும்பின்னர் (B) மற்றும்
(C) பட்டுக்கையுடன் (D) இல்லை

Which one of the following increases the functionality of a derived class and promotes reusability of the base class?

(A) Encapsulation (B) Inheritance
(C) Polymorphism (D) Object

65. விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை:

(A) விளக்கங்களை (B) விளக்கங்களை (C) விளக்கங்களை (D) விளக்கங்களை

Which of the following is a named set of defaults for formatting text?

(A) Style (B) Formatting (C) Font type (D) Points

66. மாற்றான விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை:

(A) விளக்கங்களை (B) விளக்கங்களை
(C) விளக்கங்களை (D) விளக்கங்களை

Which permits banking from the comfort of the home by using Internet facilities?

(A) e-Learning (B) e-Shopping
(C) e-Banking (D) e-Governance

67. ஓர் பின்னர் விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை விளக்கங்களை:

(A) விளக்கங்களை (B) விளக்கங்களை
(C) விளக்கங்களை (D) விளக்கங்களை

Which is the technique of distorting a single image to represent something else?

(A) Morphing (B) Animating
(C) Modeling (D) Warping
68. Which of the following does not belong to Data in the sense of Information is:

(A) Set of Processed Constant
(B) Set of Processed Data
(C) Set of Processed Command
(D) Set of Processed Operator

69. Which of the following displays the fields of a record in a well-spaced out manner?

(A) Table  (B) Form  (C) Report  (D) Query

70. When a derived class inherits only from one base class it is known as:

(A) Single Inheritance  (B) Multiple Inheritance
(C) Multilevel Inheritance  (D) Hybrid Inheritance

71. In StarOffice Base, each row in a table represents:

(A) File  (B) Field  (C) Record  (D) Data

[ நேரடையணியும்/Turn over]
72. In StarOffice Writer which command is used to insert page numbers in each page?

(A) Format → Fields → Page Number  (B) View → Fields → Page Number

(C) Tools → Insert → Page Number  (D) Insert → Fields → Page Number

73. How many field types are there in StarOffice Base?

(A) 10  (B) 20  (C) 30  (D) 40

74. In StarOffice Impress which of the following command is used to open Media Player Window?

(A) View → Media Player  (B) Format → Media Player

(C) Tools → Media Player  (D) Insert → Media Player

75. Which coloured squiggly underline is used for the words that do not match with the words in the dictionary in StarOffice Writer?

(A) Blue  (B) Green  (C) Red  (D) White
Answer any twenty questions in one or two sentences each.

76. What is text editing?

77. What is meant by autospell check icon?

78. Can we change the data present in a cell? If so, how?

79. List the types of cell referencing in StarOffice Calc.

80. What is Primary Key? Give example.

81. What is Form?

82. What is Compression? Explain the types.

83. Write short note on MIDI format.
84. How to insert and delete slide in Presentation?

85. How to start custom slide show in Presentation?

86. Define object.

87. Write note on conditional operator in C++.

88. Write about typedef with example.

89. Write down the impact of modifiers in C++.

90. Write note on nested if statement.

91. What are the types of scope of variables in C++?
92. `strlen()` பின்னர் என்கிறால் சொல்லும் தீப்பு வலைத்தொடர்.
   Write short note on `strlen()` with example.

93. அதிகாணத் தொடர் என்றா ?
   What is Matrix?

94. எந்தளவு தொடர்படும் ?
   Define Class.

95. முன்பு மகன்: (1) உடல் முறைப்படுத்துவது (2) உடல் முறைப்படுத்துவது
   Write note on (1) Data Members (2) Member functions

96. செய்யும் படிப்பு முறைப்படுத்துவது என்றா ?
   What is meant by operator overloading?

97. குறுச்சு விளம்பாகத்து பாதுகாப்பு பாதுகாப்பு ?
   What are the functions of constructor?

98. பொழுதுபொழின் அலகுகள் பாதுகாப்பு ?
   List the types of inheritance.

99. இணைய-நிராங்காக பின்னர் தீப்பு வலைத்தொடர்.
   Write note on e-Governance.

100. மீதிப்பு தொடர் என்றா ?
    What is Virus?
Answer any seven questions:

101. Write the steps involved in search and replacing a given text in StarOffice Writer.

102. In StarOffice Writer what are the various functions of the icons in the table formatting toolbar?

103. Explain how to insert objects in StarOffice Calc.

104. List the advantages of using electronic spreadsheet.

105. Explain the types of databases.

106. Explain loops with suitable example in C++.

107. Explain inline function with suitable example.

108. Define function overloading. List the rules of function overloading.
Debug the following C++ program to get the following output:

```
output
---------
3
4
5
```

Program:
---------

```cpp
#include <iostream.h>
#include <conio.h>
class A
{
    public;
    int a1,a2,a3;

    Void getdata()
    {
        a1=3;
        a2=3;a3=5;
    }
}
class B:: public A()
{
    PUBLIC

    void func()
    {
        int b1,b2,b3;
        A::getdata();
        b1=a1;
        b2=a2;
        a3=a3;
        cout<<b1<<'\t'<<b2<<'\t'<<b3;
    }

    void main()
    {
        clrscr();
        B der;
        der1:func();
        getch();
    }
```
Find the output for the following C++ program.

```cpp
#include <iostream.h>
#include <conio.h>
class sample
{
private:
    int a, b;
public:
    sample()
    {
        a = b = 0;
        cout << "\nConstructor of class sample"; 
    }
~sample()
    {
        cout << "\nDestructor of class sample"; 
    }
    void assign()
    {
        a = 25;
        b = 85;
    }
    void display()
    {
        cout << "\nThe two integers are " << a << "t" << b;
        cout << "\nThe sum of integers " << a + b;
    }
};

void main()
{
    sample obj;
    cout << "\nObject";
    obj.assign();
    obj.display();
}
```